]> git.pld-linux.org Git - packages/libsigc++3.git/blob - libsigc++3.spec
07e100543326eba11bceaf308f79c3898178b9a3
[packages/libsigc++3.git] / libsigc++3.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 %bcond_without  tests           # check target
5 #
6 Summary:        The Typesafe Signal Framework for C++
7 Summary(pl.UTF-8):      Środowisko sygnałów z kontrolą typów dla C++
8 Name:           libsigc++3
9 Version:        3.2.0
10 Release:        1
11 Epoch:          1
12 License:        LGPL v2.1+
13 Group:          Libraries
14 Source0:        https://download.gnome.org/sources/libsigc++/3.2/libsigc++-%{version}.tar.xz
15 # Source0-md5:  0bf0b7a367a30da23b4940b44ea4770e
16 URL:            https://libsigcplusplus.github.io/libsigcplusplus/
17 BuildRequires:  autoconf >= 2.59
18 BuildRequires:  automake >= 1:1.9
19 BuildRequires:  doxygen >= 1:1.8.9
20 BuildRequires:  libstdc++-devel >= 6:7
21 BuildRequires:  libtool >= 2:2.0
22 BuildRequires:  m4
23 BuildRequires:  mm-common >= 0.9.12
24 BuildRequires:  perl-base
25 BuildRequires:  pkgconfig
26 BuildRequires:  rpm-build >= 4.6
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xz
29 Obsoletes:      libsigc++-examples
30 Conflicts:      libsigc++ < 1.1.0
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 This library implements a full callback system for use in widget
35 libraries, abstract interfaces, and general programming. Originally
36 part of the Gtk-- widget set, libsigc++ is now a seperate library to
37 provide for more general use. It is the most complete library of its
38 kind with the ablity to connect an abstract callback to a class
39 method, function, or function object. It contains adaptor classes for
40 connection of dissimilar callbacks and has an ease of use unmatched by
41 other C++ callback libraries.
42
43 %description -l pl.UTF-8
44 Ta biblioteka jest implementacją pełnego systemu callbacków do
45 używania w bibliotekach widgetów, interfejsach abstrakcyjnych i
46 ogólnym programowaniu. Oryginalnie była to część zestawu widgetów
47 Gtk--, ale jest teraz oddzielną biblioteką ogólniejszego
48 przeznaczenia. Jest to kompletna biblioteka tego typu z możliwością
49 łączenia abstrakcyjnych callbacków z metodami klas, funkcjami lub
50 obiektami funkcji. Zawiera klasy adapterów do łączenia różnych
51 callbacków.
52
53 %package devel
54 Summary:        Development tools for the Typesafe Signal Framework for C++
55 Summary(pl.UTF-8):      Narzędzia programistyczne do środowiska libsig++
56 Group:          Development/Libraries
57 Requires:       %{name} = %{epoch}:%{version}-%{release}
58 Requires:       libstdc++-devel >= 6:7
59 Requires:       m4
60
61 %description devel
62 Development tools for the Typesafe Signal Framework for C++.
63
64 %description devel -l pl.UTF-8
65 Narzędzia programistyczne do środowiska libsigc++ - sygnałów z
66 kontrolą typów.
67
68 %package static
69 Summary:        Static Typesafe Signal Framework for C++ libraries
70 Summary(pl.UTF-8):      Statyczna biblioteka libsigc++
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
73
74 %description static
75 Static Typesafe Signal Framework for C++ libraries.
76
77 %description static -l pl.UTF-8
78 Statyczna biblioteka libsigc++ - środowiska sygnałów z kontrolą typów.
79
80 %package doc
81 Summary:        Reference documentation for libsigc++
82 Summary(pl.UTF-8):      Szczegółowa dokumentacja dla libsigc++
83 Group:          Documentation
84 BuildArch:      noarch
85
86 %description doc
87 Reference documentation for libsigc++.
88
89 %description doc -l pl.UTF-8
90 Szczegółowa dokumentacja dla libsigc++.
91
92 %prep
93 %setup -q -n libsigc++-%{version}
94
95 %build
96 mm-common-prepare --copy --force
97 %{__libtoolize}
98 %{__aclocal} -I build
99 %{__autoconf}
100 %{__autoheader}
101 %{__automake}
102 %configure \
103         --disable-silent-rules \
104         %{?with_static_libs:--enable-static}
105 %{__make}
106
107 %if %{with tests}
108 %{__make} check
109 %endif
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 # obsoleted by pkg-config
118 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsigc-3.0.la
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post   -p /sbin/ldconfig
124 %postun -p /sbin/ldconfig
125
126 %files
127 %defattr(644,root,root,755)
128 %doc AUTHORS ChangeLog NEWS README.md
129 %attr(755,root,root) %{_libdir}/libsigc-3.0.so.*.*.*
130 %attr(755,root,root) %ghost %{_libdir}/libsigc-3.0.so.0
131
132 %files devel
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_libdir}/libsigc-3.0.so
135 %{_includedir}/sigc++-3.0
136 %{_libdir}/sigc++-3.0
137 %{_pkgconfigdir}/sigc++-3.0.pc
138
139 %if %{with static_libs}
140 %files static
141 %defattr(644,root,root,755)
142 %{_libdir}/libsigc-3.0.a
143 %endif
144
145 %files doc
146 %defattr(644,root,root,755)
147 %{_datadir}/devhelp/books/libsigc++-3.0
148 %{_docdir}/libsigc++-3.0
This page took 0.069602 seconds and 2 git commands to generate.